Welcome to
Mod The Sims
Online: 5424
News:
Have an account? Sign in:
pass:
If you don't have an account, why not sign up now? It's free!
Other sites: SimsWiki
Reply  Replies: 6 (Who?), Viewed: 2155 times.
Search this Thread
Old 1st Aug 2018, 8:18 AM DefaultWhite texture on window is gray - What is going on? #1
fway
Original Poster

Top Secret Researcher

Join Date: Mar 2007
Posts: 1,712
Thanks: 14593 in 20 Posts
21 Achievements

View My Journal


What could cause a white texture to be gray? I've hit a roadblock here. I've edited the TXMT by changing the values of the MatDiff and the SpecCoef values both separately and together. The texture matches okay, but the color doesn't. What could be causing this? This was a Sims 3 Mesh that I converted, is there anything here that might be causing it? Is it the texture? When the object is inside it seems to fair better...

ETA: I also aligned the normals on the window as well, and smooth all.
Screenshots
Click image for larger version

Name:  Screen Shot 08-01-18 at 03.06 AM.JPG
Views: 0
Size:  436.4 KB  


Last edited by fway : 2nd Aug 2018 at 12:39 AM. Reason: Removed old file
Old 1st Aug 2018, 1:34 PM #2
simmer22
Mad Poster

Join Date: Mar 2006
Posts: 6,246
Thanks: 3 in 1 Posts
3 Achievements


The stdMatDiffCoef on 0.8,0.8,0.8 makes textures darker, but a lot of ingame textures have this setting so I'm not sure if changing it would make a big difference. The stdMatSpecCoef might also have something to say, though it should only modify the shine on the object. The texture you have is also quite gray, so there's a chance the combination is doing this.

A lot of ingame windows are quite dark. Could be something with the outside light. Does it look quite as dark indoors?
Old 1st Aug 2018, 5:24 PM #3
fway
Original Poster

Top Secret Researcher

Join Date: Mar 2007
Posts: 1,712
Thanks: 14593 in 20 Posts
21 Achievements

View My Journal


Quote:
Originally Posted by simmer22
The stdMatDiffCoef on 0.8,0.8,0.8 makes textures darker, but a lot of ingame textures have this setting so I'm not sure if changing it would make a big difference. The stdMatSpecCoef might also have something to say, though it should only modify the shine on the object. The texture you have is also quite gray, so there's a chance the combination is doing this.

A lot of ingame windows are quite dark. Could be something with the outside light. Does it look quite as dark indoors?


I think it might be GunMod's lighting mod, because I played with the texture to be whiter, and I modified the stdMatDiffCoef a bit and the texture matches best on the inside better than the outside, however I may have to adjust the opacity of the wood texture, because currently it looks flat. Just to add I'm playing in Riverblossom Hills (I don't think that has any affect though). The original object was the "Independent Expressions 'Shop Window.'" I removed the previous image

Edit: I removed GunMod's lighting mod, which didn't have any affect. Then I edited the TXMT once again, and this seems to work. Now it looks like it depends on where the light is hitting the object because the texture outside is fine for this window, but on the other wall, it looks darker. However there aren't any shadows covering it or whatnot. I tried it with some other windows, however, and it seems to have a similar effect.

Edit 2: Not everything is Okay... it appears at night that the inside windows go dark and then the outside windows turn to my desired outcome. Ugh! What did I do incorrectly? Is it the mesh verticies?
Screenshots
Click image for larger version

Name:  Screen Shot 08-01-18 at 01.51 PM.JPG
Views: 0
Size:  457.2 KB   Click image for larger version

Name:  Screen Shot 08-01-18 at 02.31 PM.JPG
Views: 0
Size:  346.5 KB  


Last edited by fway : 1st Aug 2018 at 7:34 PM. Reason: Updated image after playing with files
Old 1st Aug 2018, 10:24 PM #4
simmer22
Mad Poster

Join Date: Mar 2006
Posts: 6,246
Thanks: 3 in 1 Posts
3 Achievements


Have you tried putting lights indoors? Could be they're just not lighted up properly. You'd also want to compare your winow to a similar window ingame, just to make sure you're not trying to correct something that's a known ingame bug. I know a lot of the windows are darker than they're supposed to be, in different lighting.

I tend to get mixed results with the defeault Align Normals. Have you tried Cat's normal smoother? Might help. It does seem to work a little better than the default smother in Milkshape, though I haven't tested them side by side. http://modthesims.info/showthread.php?t=301473
Last edited by simmer22 : 1st Aug 2018 at 10:43 PM.
Old 1st Aug 2018, 11:02 PM #5
fway
Original Poster

Top Secret Researcher

Join Date: Mar 2007
Posts: 1,712
Thanks: 14593 in 20 Posts
21 Achievements

View My Journal


Quote:
Originally Posted by simmer22
Have you tried putting lights indoors? Could be they're just not lighted up properly. You'd also want to compare your winow to a similar window ingame, just to make sure you're not trying to correct something that's a known ingame bug. I know a lot of the windows are darker than they're supposed to be, in different lighting.

I tend to get mixed results with the defeault Align Normals. Have you tried Cat's normal smoother? Might help. It does seem to work a little better than the default smother in Milkshape, though I haven't tested them side by side. http://modthesims.info/showthread.php?t=301473

Yes, with lights surrounding the window, interestingly no matter which way the footprint is placed, whatever is attached to the outside wall stays bright, but the inside goes out when it's dark out. When the clock is set to a daylight time, the outside goes dark and the inside goes brighter. Is it possible for the mesh to be backwards?

I'll have to try Cat's normal smoother out! Thank you.

Edit: I've attached photos of what is going on. Also I noticed that the diagonals don't seem to be having this issue.

Edit 2: I've figured out what happened! It appears that the "Independent Expressions" shop window (the window I cloned from) is broken. The s and the n files are inverted. I got the window to light correctly, but now it's a matter of fixing the mesh to line up with the window again.

Edit 3: Mesh is fixed! There's a little bit of clipping between the north and south meshes, but that can be adjusted.
Screenshots
Click image for larger version

Name:  Screen Shot 08-01-18 at 07.03 PM.JPG
Views: 0
Size:  495.0 KB   Click image for larger version

Name:  Screen Shot 08-01-18 at 07.05 PM.JPG
Views: 0
Size:  407.7 KB   Click image for larger version

Name:  Screen Shot 08-01-18 at 07.29 PM.JPG
Views: 0
Size:  406.9 KB   Click image for larger version

Name:  Screen Shot 08-01-18 at 07.26 PM.JPG
Views: 0
Size:  447.5 KB   Click image for larger version

Name:  woohoo.jpg
Views: 0
Size:  171.0 KB  


Last edited by fway : 2nd Aug 2018 at 1:25 AM. Reason: Added Pictures, yay it was the object I cloned from! Got it to work.
Old 2nd Aug 2018, 3:22 AM #6
simmer22
Mad Poster

Join Date: Mar 2006
Posts: 6,246
Thanks: 3 in 1 Posts
3 Achievements


One tip for rotating in Milkshape (to avoid normal issues)

- Make an extra workfile (just so you don't bork anything in your current workfile)
- Make sure Autosmooth is unticked
- Add a joint approximately in the middle of the mesh ("Model" menu, click "joint", then click where you want the joint and move it around if needed)
- Add all vertices or groups you want to turn to the joint in the Joint menu, with 100% weight
- Go to Model menu, turn on animation
- click "rotate" at the top right, write "180" in the Y box, and click the "rotate" button next to the XYZ boxes. You can also move the joint around to get the window better lined up.
- Delete everything you don't need, then export as OBJ
- Open the original workfile, import the turned OBJ mesh
- Continue working on the file

I don't think you can mirror anything using this method, but it's super useful for rotating because you get no normals issues.
Old 2nd Aug 2018, 2:41 PM #7
fway
Original Poster

Top Secret Researcher

Join Date: Mar 2007
Posts: 1,712
Thanks: 14593 in 20 Posts
21 Achievements

View My Journal


Quote:
Originally Posted by simmer22
One tip for rotating in Milkshape (to avoid normal issues)

- Make an extra workfile (just so you don't bork anything in your current workfile)
- Make sure Autosmooth is unticked
- Add a joint approximately in the middle of the mesh ("Model" menu, click "joint", then click where you want the joint and move it around if needed)
- Add all vertices or groups you want to turn to the joint in the Joint menu, with 100% weight
- Go to Model menu, turn on animation
- click "rotate" at the top right, write "180" in the Y box, and click the "rotate" button next to the XYZ boxes. You can also move the joint around to get the window better lined up.
- Delete everything you don't need, then export as OBJ
- Open the original workfile, import the turned OBJ mesh
- Continue working on the file

I don't think you can mirror anything using this method, but it's super useful for rotating because you get no normals issues.


Thank you for this tip. Using “Mirror Front <———> Back” (I forgot about it, it’s been a while since I meshed anything) also works. The objects came out fine in-game.

I made some more sizes. For good measure I used Cat’s smooth normals plugin on the meshes. I’m on my phone at work at the moment, I’ll post pictures later.


Reply


Section jump:


Powered by MariaDB Some icons by http://dryicons.com.