Welcome to
Mod The Sims
Online: 6472
News:
Have an account? Sign in:
pass:
If you don't have an account, why not sign up now? It's free!
Other sites: SimsWiki
Reply  Replies: 18 (Who?), Viewed: 2242 times.
Search this Thread
Old 22nd Mar 2018, 2:07 AM DefaultDownload Page Text Not Displaying Special Characters Anymore #1
Zarathustra
Original Poster

Mad Poster

Join Date: May 2010
Posts: 3,141
Thanks: 9082 in 61 Posts
27 Achievements

View My Journal


Looking at my scorecard today, I noticed that the link to my Cárdenas Rail Station & Harvey House - NO CC lot was no longer properly displaying the accented 'a' character in the name correctly, but instead had the diamond question mark that indicates an unknown character. When I went into the download page, I also noticed that many of the characters in the description text (even when they weren't 'special' characters, but just things like apostrophes or quotation marks) also weren't displaying correctly, instead being replaced by a random collection of characters.

I know this is new, since it's been the case for a while now that quotation marks and apostrophes from a Word document don't translate over to the MTS platform, and so one of the more tedious steps in uploading any of my creations has always been going in and replacing them with the apostrophes or quotation marks on the platform itself, and aside from a few that I've missed, the text when I uploaded it wouldn't have had these errors.

What changed, and (more importantly) can it change back?

ETA: As I kind of expected, the same thing is happening with this post too...

Welcome to the Dark Side...
We lied about having cookies.
Old 22nd Mar 2018, 2:38 AM #2
Charmful
Link Ninja

Join Date: Feb 2007
Posts: 3,139
Thanks: 605 in 19 Posts
16 Achievements

View My Journal


Same issue happening with my story post. I have a ticket open and i think it had to do with a recent encoding change. I hope it's fixed soon!

Uh oh! My social bar is low - that's why I posted today.

Old 23rd Mar 2018, 2:04 AM #3
SimmyRN
Scholar

Join Date: May 2007
Posts: 1,067
Thanks: 25882 in 58 Posts
20 Achievements


Yes, the same thing happened to me. I've gone through all of my neighborhood uploads fixing apostrophes and dashes and removing simoleons signs. I haven't done anything yet with my other uploads. Quite a pain. I, too, hope it's fixed soon.
Old 23rd Mar 2018, 8:45 AM #4
Tashiketh
Warrior Gryphon



Join Date: May 2004
Posts: 9,925
Thanks: 85801 in 18 Posts
28 Achievements

View My Journal


I already fixed this yesterday

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Old 23rd Mar 2018, 3:44 PM #5
Zarathustra
Original Poster

Mad Poster

Join Date: May 2010
Posts: 3,141
Thanks: 9082 in 61 Posts
27 Achievements

View My Journal


Quote:
Originally Posted by Tashiketh
I already fixed this yesterday


Unfortunately it's still not fixed... In Chrome and Edge, special characters just show up as the diamond-question-mark symbol now...

Welcome to the Dark Side...
We lied about having cookies.
Old 23rd Mar 2018, 3:58 PM #6
Tashiketh
Warrior Gryphon



Join Date: May 2004
Posts: 9,925
Thanks: 85801 in 18 Posts
28 Achievements

View My Journal


Argh! It's definately working fine in this thread so.... and I know I fixed it yesterday on downloads. Let me go look again....

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Old 23rd Mar 2018, 4:04 PM #7
Tashiketh
Warrior Gryphon



Join Date: May 2004
Posts: 9,925
Thanks: 85801 in 18 Posts
28 Achievements

View My Journal


Okay I turned back on the conversion of w1250 to utf8 encoding. So now it should work

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Old 23rd Mar 2018, 4:09 PM #8
Zarathustra
Original Poster

Mad Poster

Join Date: May 2010
Posts: 3,141
Thanks: 9082 in 61 Posts
27 Achievements

View My Journal


Seems to have worked for the descriptive text, the download link from the search page still shows the diamond though... ¯\_(ツ)_/¯

ETA: Seems fully fixed now... hopefully?

Welcome to the Dark Side...
We lied about having cookies.
Last edited by Zarathustra : 23rd Mar 2018 at 4:32 PM.
Old 23rd Mar 2018, 7:56 PM #9
Charmful
Link Ninja

Join Date: Feb 2007
Posts: 3,139
Thanks: 605 in 19 Posts
16 Achievements

View My Journal


nay, a bunch of my older story chapters are back to question marks in diamonds for all apostrophes and quotes with the rollback. I may just have to manually update all 40-some to fix it :/

Uh oh! My social bar is low - that's why I posted today.

Old 24th Mar 2018, 7:20 AM #10
Blackgryffin
Instructor

Join Date: Apr 2006
Posts: 451
Thanks: 46107 in 147 Posts
22 Achievements


As for me, the problem persists when copy from a wordpress in utf-8.
I corrected the question mark from "Année" and got a strange combo instead - just for info. Not that I really care that I can't put "é".
Ah yes, also : for me it displays correctly at first. I get the question mark symbols in the PM notification and when I edit. Otherwise, I wouldn't know they're there.

i made a sims world ... can you believe it ? Lost Cove
Old 26th Mar 2018, 12:40 PM #11
Stopandsim
Test Subject

Join Date: Mar 2018
Posts: 2


Guys, what's going on? Special characters are not displayed correctly. What to do? My friend Secret ™ (http://www.modthesims.info/m/9838637) can not log into your account. Where are the moderators and admins. When will fix bugs and where to handle complaints? User Secret ™ was out of the MTS. It is not right!
Old 26th Mar 2018, 12:42 PM #12
maxon
The Great AntiJen



Join Date: Nov 2004
Posts: 12,645
Thanks: 8333 in 44 Posts
27 Achievements


Ah - someone contacted me @Tashiketh about not being able to PM this user: http://modthesims.info/member.php?u=10055048

Similar problem?

tflc is my tumblr with uploads not uploaded here: https://www.tumblr.com/blog/tflc
and my site, tflc: https://littlecarping.com/mybb/

Polgannon: Who Murdered Blaise Penhaligan?
(3rd ed. neighbourhood now available with corrections). Poll: http://strawpoll.me/6689876
Old 26th Mar 2018, 12:50 PM #13
Stopandsim
Test Subject

Join Date: Mar 2018
Posts: 2


May be. I dont know. "The username or password you entered is incorrect". There were no letters.
Old 26th Mar 2018, 1:44 PM #14
Tashiketh
Warrior Gryphon



Join Date: May 2004
Posts: 9,925
Thanks: 85801 in 18 Posts
28 Achievements

View My Journal


Quote:
Originally Posted by Charmful
nay, a bunch of my older story chapters are back to question marks in diamonds for all apostrophes and quotes with the rollback. I may just have to manually update all 40-some to fix it :/


Displaying stories (like http://www.modthesims.info/showthread.php?t=582545 ) should work now, as should Editing.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Old 26th Mar 2018, 6:04 PM #15
Charmful
Link Ninja

Join Date: Feb 2007
Posts: 3,139
Thanks: 605 in 19 Posts
16 Achievements

View My Journal


Quote:
Originally Posted by Tashiketh
Displaying stories (like http://www.modthesims.info/showthread.php?t=582545 ) should work now, as should Editing.


@Tashiketh thank you, truly. You saved me from many more hours of editing it's looking good for me as of this morning.

Uh oh! My social bar is low - that's why I posted today.

Old 5th Apr 2018, 7:17 AM #16
SkyeBanshee
Test Subject

Join Date: Apr 2018
Posts: 41


Quote:
Originally Posted by maxon
Ah - someone contacted me @Tashiketh about not being able to PM this user: http://modthesims.info/member.php?u=10055048

Similar problem?


Identical problem for me. This used to be my username - http://www.modthesims.info/member.php?u=4914505

I woke up yesterday morning, completely logged out for the first time in prolly two years. I try logging back in only to get told my email/password is incorrect, even though I had it saved in my browser to avoid getting that error message. Delete my old account, fix the issue, I don't care! It's highly annoying, either way!
Old 5th Apr 2018, 3:29 PM #17
Tashiketh
Warrior Gryphon



Join Date: May 2004
Posts: 9,925
Thanks: 85801 in 18 Posts
28 Achievements

View My Journal


You can also login using your email address as a username, if it contains weird characters and can't now be logged in.

I'm trying to fix the issue but it's an old codebase, and doesn't *really* like UTF-8.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Old 6th Apr 2018, 3:38 AM #18
SkyeBanshee
Test Subject

Join Date: Apr 2018
Posts: 41


Quote:
Originally Posted by Tashiketh
You can also login using your email address as a username, if it contains weird characters and can't now be logged in.

I'm trying to fix the issue but it's an old codebase, and doesn't *really* like UTF-8.


Sadly, I don't even remember the email address I used for that old account...likely an email I stopped using years ago... Honestly, I've been wanting to change my user name for ages and never could figure out how, so I don't care if the old account gets deleted or not. It's just annoying to have to get a user name change 'cuz I had to make a new account.
Old 14th Apr 2018, 8:55 PM #19
Zarathustra
Original Poster

Mad Poster

Join Date: May 2010
Posts: 3,141
Thanks: 9082 in 61 Posts
27 Achievements

View My Journal


And now it's back to not working... showing random other characters instead of the special characters that it should.

Welcome to the Dark Side...
We lied about having cookies.
Reply


Section jump:


Powered by MariaDB Some icons by http://dryicons.com.