Welcome to
Mod The Sims
Online: 5841
News:
Have an account? Sign in:
pass:
If you don't have an account, why not sign up now? It's free!
Other sites: SimsWiki
Reply  Replies: 3 (Who?), Viewed: 2348 times.
Search this Thread
Old 31st Jan 2019, 3:14 AM DefaultBlue/purple skin bug #1
Pideli
Original Poster

Forum Resident

Join Date: Aug 2011
Posts: 662
Thanks: 121 in 2 Posts
8 Achievements


So since I started this new skin recoloring project, every time I've edited the skins they turn out blue/purple in Bodyshop. I definitely didn't paint them this color. I've tried exporting the file anyway, and it is still blue/purple in the exported file and when you view the textures in SimPE so it isn't just a preview issue. The only solution I found is to save the images again in Paint (without making any changes). But that's obviously an extra step I don't want to have to go through. Any ideas how to fix it?
Screenshots
Click image for larger version

Name:  blue purple skin.JPG
Views: 0
Size:  46.3 KB  
Old 31st Jan 2019, 10:16 PM #2
simmer22
Mad Poster

Join Date: Mar 2006
Posts: 6,263
Thanks: 3 in 1 Posts
3 Achievements


Do you use Gimp by any chance? It's known to do some weird things to textures if you don't save the BMP files with the proper settings. 24-bit BMP or some such. It's possible Paint has the same issue with the files (and if it's regular Paint, you really don't want to use it because the quality is horrible).

If you can't figure it out, export regular PNG files and replace them in SimPE (use DXT3 or 5, NOT DXT1 or regular Import). Remember to compress the file after (with the Compressorizer), because otherwise it'll end up being quite large.
Last edited by simmer22 : 1st Feb 2019 at 4:38 PM.
Old 31st Jan 2019, 10:39 PM #3
Pideli
Original Poster

Forum Resident

Join Date: Aug 2011
Posts: 662
Thanks: 121 in 2 Posts
8 Achievements


Yes I do use GIMP. I just use the "overwrite" feature for the body textures since it's the quickest. But I use Export for faces and baby skins since they require some selection that I've saved as a template. I don't think the problem appears until after I've done the faces, so that could be it! (It looks normal in the projects folder btw, if I didn't make that clear.) But the body textures also turn out purple so I'm not sure. I'm done with the project now though but good to know for the future. I'll check the settings before I export. Thank you!
Old 1st Feb 2019, 4:39 PM #4
simmer22
Mad Poster

Join Date: Mar 2006
Posts: 6,263
Thanks: 3 in 1 Posts
3 Achievements


Pretty sure it's to do with the saving, even if the texture files look normal - I think Bodyshop can't properly process the format Gimp uses as a default setting for BMP files.

I think you have to do "save as..." and not "save", and pick the right option (24-bit BMP, unless my memory is completely off).
Reply


Section jump:


Powered by MariaDB Some icons by http://dryicons.com.