Welcome to
Mod The Sims
Online: 1615
News:
Have an account? Sign in:
pass:
If you don't have an account, why not sign up now? It's free!
Other sites: SimsWiki
Reply  Replies: 1 (Who?), Viewed: 3781 times.
Search this Thread
Old 19th Apr 2018, 12:07 AM Error message from Mesh Toolkit | SOLVED #1
LisaTheCupcake
Original Poster

Test Subject

Join Date: Nov 2017
Posts: 6


Hello everyone, I hope this is the right section to post this in.

I've been trying to mesh an clothing object for my sims (to be specific, a bridle for my horse sims)
I now wanted to assign my joints to my new mesh, but I keep getting this error message (both have the same group count):

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at WindowsFormsApplication1.Toolkit_MainForm.AutoWSOboneGo_button_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8825 (WinRelRS3.050727-8800)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
MeshToolKit
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///A:/Programme%20(86x)/Electronic%20Arts/Die%20Sims%203%20CC%20Programs/MeshToolKit_1_3_0_0/MeshToolKit.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8825 (WinRelRS3.050727-8800)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8825 (WinRelRS3.050727-8800)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8825 (WinRelRS3.050727-8800)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
XmodsDataLib
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///A:/Programme%20(86x)/Electronic%20Arts/Die%20Sims%203%20CC%20Programs/MeshToolKit_1_3_0_0/XmodsDataLib.DLL
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8825 (WinRelRS3.050727-8800)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
XmodsToolsLib
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///A:/Programme%20(86x)/Electronic%20Arts/Die%20Sims%203%20CC%20Programs/MeshToolKit_1_3_0_0/XmodsToolsLib.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


I hope someone can help me with this issue

Additional Information that might help:
- I have .NET 3.5 and 4.7 installed
- My TSRW version is 2.2.56
- I use Blender to modify or make a new mesh and then use Milkshape to convert the .obj file into a .wso file to be able to use it in Mesh Toolkit.
- I get the same error message by every .wso file (no matter if modified or not) even if I just want to Examine WSO under TSRW tools.
Screenshots
Click image for larger version

Name:  hgfshstrh.png
Views: 0
Size:  46.5 KB  
Last edited by LisaTheCupcake : 20th Apr 2018 at 10:09 AM.
Old 20th Apr 2018, 10:08 AM #2
LisaTheCupcake
Original Poster

Test Subject

Join Date: Nov 2017
Posts: 6


I'll write this for the people that might had, have or will have the same problem

It seems that the latest version of TSRW has changed the WSO format and so they are no longer compatible. Which is why this error message appears.
However the GEOM files still work. So another way would be to export the GEOM, do the bone assignments in Mesh Toolkit, import the GEOM back into the package.

Thanks to CmarNYC for helping me!
Reply


Section jump:


Powered by MariaDB Some icons by http://dryicons.com.