Welcome to
Mod The Sims
Online: 1580
Have an account? Sign in:
If you don't have an account, why not sign up now? It's free!
Other sites: SimsWiki
Reply  Replies: 9 (Who?), Viewed: 10757 times.
Search this Thread
Old 6th Mar 2012, 10:22 AM Unable to launch Sims Makin Magic #1
Original Poster

Test Subject

Join Date: Dec 2010
Posts: 2

(posted here because there was no sims 1 in the sims subforums)

I have gotten sims makin magic by ebay and have it installed, but every time i try to launch it a second time, the first loading screen come up and a few seconds later, a blank error box comes up and the game won't launch. The only way i know how to fix it is by reinstalling it, but it can only be played once then needs to be reinstalled to be played again. My computer is a 32-bit Windows 7

Has anyone had the same problem? If so, How do i fix it?
Last edited by OmegaDragon42 : 6th Mar 2012 at 11:34 AM.
Old 6th Mar 2012, 11:41 AM #2
Mad Poster

Join Date: Dec 2004
Posts: 7,508

I had this problem and don't exactly remember the fix. It had to do with the whole "administrative privileges" on Vista that is another step then simply right clicking and choose "run as administrator". If you google Vista + Sims 1 you can find some forums to help. I wish I could remember who actually did help - it was some technical forum. There are a few out there that suggest changing the compatibility mode for your computer, but that wasn't what helped me.

Addicted to The Sims since 2000.
Old 6th Mar 2012, 11:49 AM #3
Original Poster

Test Subject

Join Date: Dec 2010
Posts: 2

Using Run as Administrator actualy work! Thanks!
Old 6th Mar 2012, 9:06 PM #4
Mad Poster

Join Date: Dec 2004
Posts: 7,508

Oh, I'm so glad! Boy, that was easy!

Addicted to The Sims since 2000.
Old 7th Mar 2012, 2:11 PM #5
Be like the 22nd elephant with heated value in space- Bark!

Join Date: Feb 2005
Posts: 18,970
Thanks: 8861 in 32 Posts
19 Achievements

View My Journal

In future, the best location to install games (especially older games like Sims original, which store the user files to the install directory) is to a new folder in the root of your hard drive.

For example, I have a folder C:\ Games which I install all of my games to, so I have my Sims game in C:\Games\Maxis\The Sims.

This is because the system files (Program Files, Windows folders) are protected by UAC in Vista and Windows 7, and so programs that you install there are not allowed administrator priveleges as standard. Legacy programs will be virtualized.
Old 6th May 2012, 4:17 PM Defaultstill messed up #6
Test Subject

Join Date: May 2012
Posts: 1

I had The Sims (with all six major expansions) on my old XP computer, and everything worked fine. I replaced the old computer last fall with a new Windows 7 computer. This week, I decided to install The Sims on the new computer. Like many other people, I've had problems. The game worked upon initial installation, but I was unable to re-start the program a 2nd time, and eventually, uninstalled it. I reinstalled it again (in chronological order of The Sims expansions release dates, instead of the Expansion Collection set ordr), it failed again. Uninstalled. Then I went online to get help.

I read the info about creating a Games folder in the C: drive, instead of the program folder...that didn't fix it. I tried running the program as XP...didn't fix it. Then I played the game using the right click/"run as administrator". The program did run...but with some problems. One...it defaults to the small screen 800x600 version, when I prefer the 1024x768 version (which requires less flipping though the lists of options...wall treatments, floor coverings, furniture). No big deal, if that were the only problem. BUT, as I was originally installing the expansions to see what each expansion added to the game (new faces, bodies, furniture, wall paper types, floor cover types, etc)...I knew more or less, exactly what the end looked like (96 different adult male heads, 108 adult male bodies...289 different wall treatments...193 different floor coverings....26 dining room chairs)...and 26 different misc. furnishings, including 4 different trash cans (the gray, black, barrel & elephant foot). I only mention it, because when I play the game "as administrator"...it only has two of the waste cans. Which means, there's likely a bunch of other items that are left off. When I open up the premade houses, several say that there are graphics missing (because they're not loading up).

Some smart-asses out there recommend playing The Sims 2 or 3, because they're better games. First off...they are DIFFERENT games. But, "better" is a subjective term. 2 & 3 have better graphics, and the sim-relationship stuff is improved...but the original game has quite a few advantages over its sequels...for one...it's a much better HOME builder game...with many more decor options and structural options, two floors, the variety of pets (beyond cats & dogs), the magic stuff, and many other offerings its expansions added, that were not carried over into 2 & 3. Like most game series, all three each have something the other two don't have. I'm sure there are some people who love the way 2 plays over 3...and there are people who love 3 much more than 1 or 2. Each game gives the player different things from which to enjoy. I have 2 on the PS2, and think its great. But prefer the extensive home design options available on 1. (That, and after purchasing all the expansions of the first game...I really don't want to invest in buying all the expansions of the 2nd or 3rd versions...just in time for version 4 to come out).

But, back to the problem.

Is there ANYTHING I can do, to play The Sims...with all its expansions...on System 7...WITHOUT losing items in the game...or having to reinstall it every time I play (since it takes around 45 minutes to install them...after doing so 4 times, I'm getting close to memorizing the seven different serial number codes), or just leaving the program running in the background all the time?

Or at least answer me this...why does it work perfectly upon installation...but not subsequent operations of the game? All the same stuff is on the computer...it hasn't moved.

I've read several other posts online, and several were under the impression that it was just Makin Magic that was causing the problem. It isn't. As I was installing each expansion the first time through, I opened up the game to catalog all the stuff that was added by that version...and I had issues after Unleashed as well. The program thinks expansions were added after that major version was installed (major being one which uses the expansion disc instead of the previous disc to run the game...ie once all expansions are installed, it uses the Makin Magic disc to play the game), and makes the program want to reinstall...or uninstall...the program. I was hoping that if Makin Magic was the LAST program to be installed, it would solve the problem...but it didn't (that's what I attempted to do on my 2nd 45 minute reinstall).

What really ticks me off, is that after the initial install (and 2nd one)...I took time to design a house and make a family to put into the house...just to lose all the work I put into it when I had to uninstall it. I learned my lesson on the 3rd & 4th installs.

There has to be an answer, but I don't know enough about how these PC's run, to figure it out.

I currently have the game (and all 6 expansions) installed in C: in a games folder instead of the programs folder, and can only run the game (albeit with missing items) if I run it as administrator.
Last edited by msmilder : 6th May 2012 at 4:27 PM.
Old 8th May 2012, 2:07 AM #7
Moderator of Camera Models

Join Date: Sep 2004
Posts: 1,559
Thanks: 402 in 6 Posts
6 Achievements

If you've not tried the official EA forums yet I'd also pop your question in there to increase your chances of getting a satisfactory answer. Alas I don't have one for you myself.

*** Games Journalist with the magazines PC Powerplay and Hyper ***

And guys don't say a game is 'addicting'. That is a horrible massacre of the English language. The word is 'addictive'. Thank you. :)
Old 9th May 2012, 3:35 PM #8
Rock Chick

Join Date: Nov 2005
Posts: 944
Thanks: 29299 in 138 Posts
23 Achievements

Hi, I have googled most of the day on this problem and about to tear my hair out. EA site does not have any help with patches or tips.
I have windows 7 home edition, have installed the sims 1complete collection to my D drive in its own folder (eg not into program files as above)
tried compatibility mode for xp service pack 2/vista/98/95 plus run as administrator and disable visual themes checked also...so why on earth will some peoples windows 7 allow it to work and others not?
Not expecting anything really, just nowhere to go and a bit disappointed at the moment. Foxed even!

Installed fine but will not even start for a few seconds.
Old 27th Sep 2017, 11:23 AM #9
Test Subject

Join Date: Sep 2017
Posts: 1

Hi all I have installed Sims 1 and all the expansions I go to launch it through the making magic disc or through a short cut on the desktop and it won't launch I have set it to run as administrator and I have uninstalled the windows update.
pls help as I'm pulling my hair out.
Many thanks
Old 27th Sep 2017, 11:52 AM #10
Née whiterider

Join Date: Jul 2005
Posts: 19,763
Thanks: 42977 in 82 Posts
36 Achievements

View My Journal

I can't believe you've managed to a necro a thread that ElPres posted in, I'd honestly forgotten he existed.

What I lack in decorum, I make up for with an absence of tact.

Section jump:

Powered by MariaDB Some icons by http://dryicons.com.