PDA

View Full Version : Problems with my MAXIS cloned fence (solved)


SimSamBol
29th Jun 2008, 3:42 PM
Hi, all!

Now I've got a problem with a fence I cloned from a MAXIS one. I've changed a little the "position" of it for it appear closer to the oposite wall (or tile) I build. But it doesn't work as well as it should/I wanted. Look the attached image.

Look the "real" fence (number 1). This is the right position of it, buit the two details (number 2), aren't showing up just beside the fence; and I did put them with the fence in the Blender. Why is it happening? Is there a way to fix it? Can I delete those fence details (2)?

It have to work as these balconies:

http://thumbs2.modthesims2.com/images19/MTS2_473133_macarossi_thumb_WindowBalcony.jpg

Thanks,

Samuel.

Numenor
1st Jul 2008, 12:53 AM
Getting rid of the "detail" (better: "post") should be quite easy...
Open the Fence XML file, locate the "post" entry and delete the filename associated to it; this way, no post will be placed between the fence sections.

If, on the other hand, you want to keep the post, but in the right position, then there's no other way but proceeding by trials and errors, moving the mesh in the 3D editor and trying again in game. But the result won't be good in any case, because the post, by default, is centered on the axis, in the 3D editor; and if you move it off-center, you might have unpredictable results when in game (e.g. the position is correct when drawing the fence left to right, but it's greatly misplaced when drawing right to let, or in diagonal).